Durch Struktogramme lassen sich Algorithmen leichter nachvollziehen. Häufig ist der Quelltext einen Karol-Programms nicht aufschlussreich und unübersichtlich.

Sequenz

Eine Sequenz ist eine Abfolge von Anweisungen, die nacheinander ausgeführt werden.

Im Struktigramm zieht man um diese einen Kasten.

z.B.

Schritt 
Hinlegen
Schritt

Wiederholung

Durch Wiederholungen lassen sich Sequenzen Wiederholen.

Im Struktogramm ist die Wiederholung ein großer Kasten. Die zu wiederholende Sequenz wird in diesen großen Kasten (in einem eigenen kleineren Kasten) eingetragen.

z.B.

Wiederhole 4 mal
Schritt
Hinlegen
*wiederhole

oder

Wiederhole immer
Schritt
Hinlegen
*wiederhole

oder

Bedingung

Durch Bedngungen muss Robot Karol abhängig von der Bedingung von zwei Sequenzen diejenige auswählen, die er ausführen soll.

Diese Situation nennt man bedingte Anweisung oder Auswahl

wenn IstZiegel() dann
     Aufheben ()
sonst
     Schritt() 
*wenn

Kommentieren Kommentare