Suche
suchen

Aufgaben zu Robot Karol

1

Erstelle eine Welt mit den Maßen 10 x10 x 10

a

Karol soll in jeder Ecke einen Ziegel ablegen!

b

Karol soll an alle Seiten Ziegel legen, sodass ein rechteckiger Ring mit den Maßen 10x10 entsteht.

2

Bau einer Burg

Karol hat einen alten Bauplan für eine große Burg gefunden. Leider ist er nicht mehr ganz vollständig. In dieser Aufgabe kannst du ihm Schritt für Schritt helfen, den Plan zu rekonstruieren und eine große Burg zu bauen. Ziel der Aufgabe ist es, trotz einem eher umfangreichen Bauprojekt, den Programmcode übersichtlich und verständlich zu gestalten. Damit dir dies gelingt, musst du zuerst einige Methoden zur Vorarbeit schreiben. Vergiss nicht dein Programm immer wieder zu speichern – besonders wenn du zwischenzeitlich ein Anderes öffnest. Die Weltgröße für dein Programm ist 15 x 15 x 10.

Autor der Aufgabe: P. Dippon, 2016 Lizenz: cc-by-sa-4.0

a

Schreibe eine Anweisung (Methode) SchrittBisWand mit der Karol bis zur Wand gerade aus läuft, egal wo er zuvor steht und eine Anweisung (Methode) Stapelaufheben bei der Karol alle Ziegel aufhebt, die unmittelbar vor ihm liegen.

b

Sieh dir den Code rechts an. Beantworte in deinem Heft die folgenden Fragen:

  • Was macht diese Anweisung?

  • Was bewirken „schnell“ und „langsam“?

Gib der Methode einen sinnvollen Namen und füge sie deinem Programm hinzu. Wenn du dir nicht sicher bist, kannst du sie in einem anderen Fenster einfach kurz testen.

Tipp: Du kannst ebenso in deinen Methoden aus a) „schnell“ und „langsam“ hinzufügen.

c

Kopiere den unteren Code für die Grundmauer der Burg in dein Programm. Du musst nur an der markierten Stelle den Namen aus Aufgabe b) eintragen, damit das Programm funktioniert. Probiere es aus!

Anweisung Bauplan
  wiederhole 4 mal
    SchrittBisWand
    //Hier muss der Name geändert werden!!
    abc
    abc
    MarkeSetzen
    LinksDrehen
  *wiederhole
*Anweisung

Anweisung Burgmauer
  wiederhole 16 mal
    Hinlegen
    Schritt
    Schnell
    wiederhole solange NichtIstMarke
      Hinlegen
      Schritt
    *wiederhole
    Langsam
    LinksDrehen
  *wiederhole
*Anweisung

LinksDrehen
Schritt
Schritt
RechtsDrehen
Bauplan
Burgmauer
d

Um weiter zu bauen soll Karol jetzt noch in die Ecke unten links gehen. Baue dazu eine Treppe von der Mauer hinunter in den Burghof und einen Ausgang aus der Burg hinaus.

e

Kopiere nun den Lückencode von unten. Mit dieser Anweisung soll Karol ein 3x3-Feld aufräumen. Dies wird benötigt, um später die Ecken der Mauer wieder abzubauen, um Platz für die Türme zu schaffen.

Ergänze die fehlenden Teile und teste die Methode. Die Skizze soll dir zeigen, wie Karol vorgeht.

Anweisung EckeLöschen
  wiederhole _ mal
    wiederhole _ mal
      Stapelaufheben
      ___
    *wiederhole
    LinksDrehen
  *wiederhole
  ___
  Schritt
  LinksDrehen
  ___
  RechtsDrehen
  Schritt
  LinksDrehen
*Anweisung
f

Ein Freund von dir hat sich für die Türme eine besondere Methode ausgedacht. Mit dieser kann Karol von einem 10 Blöcke hohen Turm „springen“. Dafür braucht er nur 2 freie Felder vor sich. Leider funktioniert die Methode nicht mehr ganz und verursacht Fehler.

Finde die drei Fehler, begründe im Heft wieso das Programm nicht funktioniert und verbessere diese.

Anweisung Sprung
  wiederhole 9 mal
    Hinlegen
  *wiederhole
  Schritt
  wiederhole 8 mal
    Hinlegen
  *wiedrehole
  wiederhole 9 mal
    Schritt
    LinksDrehen
    LinksDrehen
    Aufheben
    Aufheben
  *wiederhole
g

Mit Hilfe der Methoden EckeLöschen und Sprung kannst du nun recht einfach Türme für die Burg bauen. Achte darauf, dass die Türme auch bei größeren Welten in den Ecken der Mauern landen sollen. Schreibe dazu eine Methode TurmBauen, bei der auf ein 3x3-Feld ein 10 Ziegel hoher Turm gebaut wird. Ergänze das Programm, sodass in allen vier Ecken der Mauer Türme entstehen.

h

Teste den Burgbau auch für größere Welten. Funktioniert alles, oder musst du noch nachbessern?

Wie viele Dinge musst du mindestens ändern, wenn du andere gleich hohe Türme bauen möchtest?

Nenne mindestens zwei Gründe, warum man mit vielen eigenen Methoden arbeiten sollte. Schau dir das bisherige Programm noch einmal genau an: Kannst du alles was darin geschieht nachvollziehen, oder sind dir bestimmte Stellen unklar? Formuliere konkrete Fragen zum Programmablauf in deinem Heft und kläre diese dann mit deinem Sitznachbarn (oder schreibe hier einen Kommentar :-) ).

i

Zum Abschluss, soll die Burg noch möglichst schön gestaltet werden. Du könntest zum Beispiel Zinnen auf den Mauern verteilen, oder das Burginnere pflastern. Füge noch mindestens zwei verschönernde Elemente zu deiner Burg hinzu.


Dieses Werk steht unter der freien Lizenz
CC BY-SA 4.0.Was bedeutet das?