Bedingte Funktionen arbeiten mit Wahrheitswerten, das heißt mit WAHR und FALSCH. Bedingte Funktionen prüfen also, ob eine gewisse Aussage WAHR oder FALSCH ist und in bestimmten Fällen führen sie abhängig von dem Wahrheitswert eine bestimmte Aktion aus.

Wahrheitswerte im Alltag

Um bedingte Funktionen besser zu verstehen, kann man sich fol gende Situation aus dem echten Leben vorstellen. Man hat ein Wort geschrieben und liest nocheinmal, ob man das Wort richtig geschrieben hat. Wenn das Wort falsch geschrieben ist, bessert man den Fehler aus, wenn das Wort richtig ist, macht man nichts.

WAHR heißt, das Wort ist richtig, es muss nichts gemacht werden.

FALSCH heißt, das Wort ist falsch geschrieben, es muss verbessert werden.

Wenn

Bei der Wenn-Funktion gibt es drei Werte. Den Wahrheitswert, die Alternative bei WAHR und bei FALSCH. Wenn der Wahrheitswert

  • wahr ist, dann die Alternative bei WAHR.

  • falsch ist, dann die Alternative bei FALSCH.

Wahrheitswert:

Im Wahrheitswert steckt eine Aussagefunktion, d.h es wird eine Aussage getroffen wie z.B. 5<3 => FALSCH.

Aussagefunktionen:

a > b

a < b

a = b

a <> b (ungleich)

a >= b (größergleich)

a <= b (kleinergleich)

Die Funktion:

=WENN(Wahrheitswert;Alternative bei WAHR;Alternative bei FALSCH)

UND & ODER

UND & ODER werden verwendet, wenn es mehrere Wahrheitswerte geben soll. Es wr zwischen UND & ODER unterschieden.

ODER

Wenn einer der Wahrheitswerte richtig ist => WAHR

Wenn alle Wahrheitswerte falsch sind => FALSCH

UND

Wenn alle Wahrheitswerte richtig sind => WAHR

Wenn einer der Wahrheitswerte falsch ist => FALSCH

Beispiele

=WENN(ODER(A1<B3;A1=G5;A1>C6);100;200)

=WENN(UND(A1<B3;A1=G5;A1>C6);100;200)

Kommentieren Kommentare